Dl_config.exe does not work with "--encodeonly=true"


I am trying to start Scan2Deploy on android from our app using a launch intent. I am following this manual from Github

But I encountered two problems.

  1. The package name in the manual is incorrect. After removing .android from com.datalogic.android.scan2deploy this was fixed

  2. I could not generate encoded data using dl_config.exe --encodeonly=true

According to the documentation something like this should happen:

> dl_config.exe lock-test.json --encodeonly=true
Datalogic Staging Configurator (ver 1.6.0)
Copyright (c) 2016-2018 by Datalogic MCSA S.r.l.
Loading file 'lock-test.json'
Processing data

But I don’t see the option --encodeonly=true in the usage in my dl_config.exe from DXU v2.0

Datalogic Staging Configurator (ver 1.6.0)
Copyright (c) 2016-2017 by Datalogic MCSA S.r.l.
ERROR: bad argument(s) in command line
Usage: dl_config.exe <input-file> <output-file> [options]

When I try running with --encode-only, I get just a PDF File.

Could you provide me the right dl_config.exe?

Jan van Rosmalen

Hi Jan,

The --encode-only feature was documented, but never implemented unfortunately. I will implement this feature in an upcoming version of DXU Desktop (v2.1). It will be should be available within a month from now. I will come back here and reply once it has been made available.

Thank you!

Thanks for the reply, I will wait until then


Is this new feature implemented yet? Or could you describe how I could encode the message myself? We really need it to be able to update our application.

Also, see the “Third Party Integration” documentation here for the correct way to pass the data in an intent to the Scan2Deploy app on the device:

Hi Jan,

Sorry for the delay. DXU Desktop 2.1 has been publicly released, which includes the dl_config.exe update with the “–encodeonly” option.

Documentation has been updated accordingly.


Hi Cody,

I used the dl_config.exe bundled with DXU v2.1 and an Android Intent and it works perfectly now!

Thank you very much!