SKORPIO X5 - Not Booting

Hey guys! Need a little help!
I have a Skorpio X5 thats not booting.
When i turn it on it only appears START and i cant do anything.
None of the buttons responds.

Any ideas?
thank you.
Picture attached

Hi Joao,

This is the fastboot mode. When you press the left scanbutton when you power on the device you enter in this mode. Normally when Start is selected and you press the power key the SX5 will start normally.

When the terminal is not responding at all I would try to boot in recovery mode first by keeping the right scankey pressed while powering on. Then select the factory reset.

If that doesn’t work please send the unit to repair.

Gr Peter

1 Like

Hi Peter! Thank you for your reply.
Skorpio is not responding at all.

The power button doesnt seem to select the option and it wont boot.
Also, i’ve tried to press the left scan key several times (in case it was stuck and making the skorpio going into fast boot) and rebooted the skorpio. Same thing.

Last but not the least, i’ve tried to press the right scan button while powering on and i also go into fastboot…

RMA?

Hi Joao,

Yes please send it to repair. Sounds like a defect to me.

Gr Peter