Soti Mobicontrol DXU and Firmware update scripts

Soti Script : Firmware update:
sendIntent-s "intent:#Intent;component=com.datalogic.systemupdate/com.datalogic.systemupdate.SystemUpgradeService;i.action=2;S.path=/sdcard/;i.reset=0;i.force_update=0;end;"

Soti Script: DXU Config:
sendintent -b "intent:#Intent;action=com.datalogic.dxu.Config;S.config=/sdcard/joya.dxu;end;"


For our Android 4.4 firmware upgrade you need to use a different script:

sendIntent -s "intent:#Intent;component=com.datalogic.systemupdate/com.datalogic.systemupdate.SystemUpgradeService;i.action=2;S.path=/storage/sdcard0/;i.reset=0;i.force_update=0;end"



I´v tried to update the Firmware of a Memor 10 thru SOTI, i used this script:

sendIntent-s “intent:#Intent;component=com.datalogic.systemupdate/com.datalogic.systemupdate.SystemUpgradeService;i.action=2;S.path=/sdcard/;i.reset=0;i.force_update=0;end;”

After Download of the File , nothing happend, but the File was on the device.

With System , Update search manualy, i found the Package at /sdcard/ Folder

Hi Michael,

Just gave it a try. This worked for me:

sendIntent -s “intent:#Intent;component=com.datalogic.systemupdate/com.datalogic.systemupdate.SystemUpgradeService;i.action=2;S.path=/storage/emulated/0/;i.reset=0;i.force_update=1;end”

Gr Peter


I’m having issues updating firmware using the 1.05.13-1.07.15 incremental. It’s really hit and miss on whether or not the intent works for me, but if I go into system on the device and select the update it will apply.

Is there a log file somewhere where I can review what the intent did or did not do? Perhaps the issue is power conditions? Nothing gets reported back to MobiControl so I am left grasping at straws.

can you please file a case about it here?
this way our team can perform some tests from our end and then follow up on the issue